The following error message may appear when upgrading to Cascade 8 against a version of MySQL 5.7 prior to release 5.7.11:

Migration failed for change set com/hannonhill/cascade/model/database/updater/updates/8_0/8_0_006.xml::8_0_006::artur.tomusiak:
     Reason: liquibase.exception.JDBCException: Error executing SQL DELETE FROM `cxml_history_item`  WHERE id in (select hi.id from cxml_foldercontent fc left join (select * from cxml_history_item) hi on fc.id=hi.entityId where hi.entityId is
        not null and fc.siteId is null):
          Caused By: Error executing SQL DELETE FROM `cxml_history_item`  WHERE id in (select hi.id from cxml_foldercontent fc left join (select * from cxml_history_item) hi on fc.id=hi.entityId where hi.entityId is
        not null and fc.siteId is null):
          Caused By: You can't specify target table 'cxml_history_item' for update in FROM clause

The underlying issue is this MySQL bug which has been corrected in MySQL 5.7.11. To resolve the issue, upgrade your MySQL instance to 5.7.11 or newer.

Did this answer your question?